Symptom


Beim Update von EU Cookie auf von der Version 115 und kleiner auf eine Version 116 und größer tritt der Fehler 203 auf.


Der Fehler wird von einer zu niedrigen MySQL Version verursacht. EU Cookie nutzt Funktionalität, die in MySQL 5.5 noch nicht vorhanden ist.

EU Cookie braucht mindestens eine die MySQL Version 5.6.

Zudem wird die MySQL Version 5.5 schon seit Ende 2018 nicht mehr mit Updates versorgt und befindet sich im sogenannten "end of life" Status. und ist so potentiell angreifbar, da es Sicherheitslücken enthält, die bekannt sind


MySQL 5.5 ist potentiell angreifbar, da es Sicherheitslücken enthält, die bekannt sind


Lösung


Bitte prüfe in deinem Shop Backend, welche MySql Version auf deinem Server installiert ist. Du findest das i.d.R. in folgendem Widget:



Hier muss mindestens 5.6. stehen (gelb hinterlegt)


Ansonsten bitte deinen Hosting Provider dringend um ein Update der MySQL Datenbank auf mindesten 5.6. 


Mehr Infos: 


>> https://www.borncity.com/blog/2016/11/07/sicherheitslcke-in-mysql-und-clones-schlieen/

>> https://www.ionos.de/hilfe/hosting/mysql-datenbank-fuer-web-projekt-verwenden/mysql-55-datenbank-auf-mysql-57-umstellen/